Dependencies

OpenRazer

At minimum, the OpenRazer daemon and Python library must be installed.

  • python3-openrazer (or python-openrazer on some distros)
  • openrazer-daemon

Packages

Required

Debian/Ubuntu

Arch

openSUSE

Building

meson and ninja is required to build the project.

You’ll also need an implementation of sass to compile the styling. One way is using the ruby gem:

sudo gem install sass

The gem has since been deprecated, but it will still work. If you’d like to avoid ruby as a dependency, you can alternately install the NodeJS version using npm like so:

sudo npm install -g sass

Or download a release of dart-sass, which contains a binary that you can run.

For instructions on building, see the “Manual Installation” download page.